Установка PhpStorm Ubuntu 16.04 | Losst

Установка PhpStorm Ubuntu 16.04

Для тех, кто не знает, PhpStorm - интеллектуальный редактор для PHP, HTML и JavaScript, имеющий возможность анализировать код на лету, предотвращать ошибки в коде и не только. Автодополнение кода в PhpStorm поддерживает PHP 5.3, 5.4, 5.5, 5.6, 7.0 и 7.1.

Это проприетарное коммерческое программное обеспечение от JetBrains может работать на Linux, macOS и Windows. В данной статье будет рассмотрена установка PhpStorm Ubuntu и Oracle Java 8.

Установка Oracle Java 8 Ubuntu 16.04

Так как PhpStorm работает на Java, вам нужно установить последнюю стабильную версию Java 8 для Ubuntu 16.04 через PPA репозиторий. Если у вас установлен OpenJDK, то его нужно удалить:

$ sudo apt remove openjdk*

Теперь мы можем приступить к добавлению PPA репозитория с помощью этой команды:

$ sudo add-apt-repository ppa:webupd8team/java

Обновим список пакетов данной командой:

$ sudo apt-get update

Теперь мы можем установить сам пакет:

$ sudo apt-get install java-common oracle-java8-installer

В процессе установки Java 8 вам будет необходимо принять лицензионное соглашение Oracle.

После установки нужно будет еще указать переменные среды, такие как, например, JAVA_HOME. Указать эти переменные среды вы можете с помощью этих двух команд:

$ sudo apt-get install oracle-java8-set-default

$ source /etc/profile

Установка PhpStorm Ubuntu 16.04

Для начала нужно зайти на официальный сайт и скачать *.tar архив. Так же программу можно скачать в терминале с помощью утилиты Wget (версия пакета может быть неактуальной):

$ wget https://download-cf.jetbrains.com/webide/PhpStorm-2016.1.2.tar.gz

После завершения загрузки откройте терминал и смените рабочую директорию на каталог, в котором лежит загруженный файл. Теперь нужно распаковать *.tar.gz архив:

$ tar xvf PhpStorm-2016.1.2.tar.gz

В рабочей директории появится папка под названием PhpStorm-145.1616.3. Ее нужно переместить в /opt:

$ sudo mv PhpStorm-145.1616.3/ /opt/phpstorm/

Создайте символическую ссылку с помощью этой команды:

$ sudo ln -s /opt/phpstorm/bin/phpstorm.sh /usr/local/bin/phpstorm

Теперь вы можете запустить PhpStorm в терминале при помощи этой команды:

$ phpstorm

Если вам не нужно импортировать данные из прошлой версии PhpStorm или вы используете эту программу впервые, выберите второй пункт в этом диалоговом окне.

Прочтите и примите политику конфиденциальности.

Если вы не хотите приобретать лицензию на использование PhpStorm, вы можете использовать бесплатный пробный период в течение 30 дней.

Теперь вам нужно принять лицензионное соглашение.

В следующем окне выберите тему, цвет, шрифт и нажмите кнопку "ОК".

Далее вам нужно ввести свой пароль для создания скрипта запуска и ярлыка.

После того, как все будет сделано, вы можете приступить к работе с программой.

В следующий раз вы можете открыть программу непосредственно из Unity Dash.

Если вы хотите удалить PhpStorm, вы можете ввести эту команду в терминале:

$ sudo rm /opt/phpstorm/ -R

Выводы

Я надеюсь, что эта статья была полезной для вас и помогла установить PhpStorm Ubuntu. Комментарии и пожелания приветствуются.

Источник: www.linuxbabe.com

Редактор сайта losst.ru, увлекаюсь свободным программным обеспечением и изучаю программирование. Я использую на своём компьютере macOS.

Ваше имя тоже может быть здесь. Как? Пишите для нас! Смотрите подробнее как стать автором Losst.

Оцените статью:

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (17 оценок, среднее: 4,35 из 5)
Загрузка...

  7 comments for “Установка PhpStorm Ubuntu 16.04

  1. Январь 10, 2017 at 4:56 пп

    Спасибо, очень доходчиво!

  2. Январь 16, 2017 at 12:56 пп

    как обновить phpshtorm находящийся в opt? интерисует именно обновление штатным апдейтером, а не удалить — поставить заново.

  3. Анатолий
    Март 16, 2017 at 12:51 дп

    Что значит поменять «рабочую директорию на каталог в котором лежит загруженный файл??» Спасибо

    • Март 16, 2017 at 5:54 дп

      cd /путь/к/каталогу/где/лежит/файл/

  4. vr
    Март 22, 2017 at 2:40 дп

    Не могу понять, почему все ресурсы дают один и тот же рецепт — удалять OpenJDK и ставить от Oracle, которую собрали webupd8, если на сайте разработчики PhpStorm пишут:
    Our custom JRE is based on OpenJDK and includes the most up to date fixes to provide better user experience on Linux (like font rendering improvements and HiDPI support).
    It’s recommended to use the bundled JRE (if available). In case you have any issues with the bundled version, you can switch to the latest version of Oracle JDK or OpenJDK available for your system (OpenJDK 1.6 is not supported, please use 1.7 or later versions, JDK 1.8 is recommended and older Java versions are not supported starting from IntelliJ IDEA 16).

    Т.е. рекомендуют использовать то что идет в комплекте. А если возникают проблемы, то можно пробовать переключатся на другие версии. Личная практика показывает, что на семействе Ubuntu все хорошо (сглаживание шрифтов напр) на версии, что идет в комплекте с PhpStorm (bundled).
    Переключения на версии от Oracle или просто более новые Open могут вызвать дальнейшие танцы.

    Зачем писать следующее? ))
    «Так как PhpStorm работает на Java, вам нужно установить последнюю стабильную версию Java 8 для Ubuntu 16.04 через PPA репозиторий. Если у вас установлен OpenJDK, то его нужно удалить…»

    • vr
      Март 26, 2017 at 1:23 дп

      Нашел очень интересный момент.
      Если в системе нет установленной Java (любой), то PhpStorm работает на
      JRE: 1.8.0_112-release-736-b13 amd64
      JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
      Посмотреть можно в меню Help — > About. И мой проект в PhpStorm использует 440 Мб ОЗУ (процесс java). Если установить OpenJDK, то в Help — > About JVM не будет «by JetBrains s.r.o», не помню точный вывод. Но суть — при OpenJDK 1.8 тот же проект, при тех же настройках у меня кушал 1.2 Гб ОЗУ ! С Java Oracle не пробовал. Такие дела.

Добавить комментарий

Сообщить об опечатке

Текст, который будет отправлен нашим редакторам: